Microsoft OAuth integrations not indexing on Dev Info for Jira
Incident Report for Git Integration for Jira
Resolved
This incident has been resolved.
Posted Jul 20, 2023 - 00:27 EDT
Monitoring
A fix has been implemented. Customers who use the the OAuth integration type for Microsoft Azure Repos or Microsoft VSTS will need to reconnect. See https://help.gitkraken.com/git-integration-for-jira-cloud/reconnecting-azure-devops-and-vsts-oauth-integrations-gij-cloud/ for instructions on how to reconnect.
Posted Jun 25, 2023 - 07:17 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 25, 2023 - 07:16 EDT
Identified
Microsoft VSTS and Azure DevOps OAuth applications have a bug/limitation where the application secret expires 5 years after creation. This secret cannot be refreshed/updated. The workaround from Microsoft is to create a new OAuth application and have consumer re-connect: https://developercommunity.visualstudio.com/t/client-secret-is-expired-even-after-refresh/1564908

We will be updating production shortly. Once updated, customers will need to reconnect https://cln.sh/26TUNm in the integration settings. If you need assistance with this, please contact support@bigbrassband.com.

The application affected is Dev Info for Jira:
https://marketplace.atlassian.com/apps/1219270/dev-info-for-jira?tab=overview&hosting=cloud
Posted Jun 25, 2023 - 07:16 EDT
This incident affected: Git Integration for Jira Cloud - Global Region.